164 lines
5 KiB
RPMSpec
164 lines
5 KiB
RPMSpec
#
|
|
# spec file for package iproute2
|
|
#
|
|
# Copyright (c) 2022-2023 ZhuningOS
|
|
#
|
|
|
|
# ---------------------------------------------------------------------------
|
|
# Contents of this package is exported from git repository; please submit
|
|
# your changes via https://gitlab.suse.de/mkubecek/iproute2-source or
|
|
# gitlab@gitlab.suse.de:mkubecek/iproute2-source.git rather than to IBS.
|
|
# ---------------------------------------------------------------------------
|
|
|
|
%define _buildshell /bin/bash
|
|
Name: iproute2
|
|
Version: 5.14
|
|
Release: 150400.1.8
|
|
Summary: Linux network configuration utilities
|
|
License: GPL-2.0-only
|
|
Group: Productivity/Networking/Routing
|
|
URL: https://wiki.linuxfoundation.org/networking/iproute2
|
|
# Using GPL-2.0 instead of GPL-2.0+ because of tc_skbedit.h and tc/q_multiq.c
|
|
|
|
#DL-URL: https://kernel.org/pub/linux/utils/net/iproute2/
|
|
#Git-Clone: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/
|
|
Source: https://kernel.org/pub/linux/utils/net/iproute2/%name-%version.0.tar.xz
|
|
Source2: https://kernel.org/pub/linux/utils/net/iproute2/%name-%version.0.tar.sign
|
|
Source3: patches.tar.xz
|
|
Source4: series.conf
|
|
Source5: guards
|
|
Source6: apply-patches
|
|
Source9: %name.keyring
|
|
BuildRequires: bison
|
|
BuildRequires: db-devel
|
|
BuildRequires: fdupes
|
|
BuildRequires: flex
|
|
BuildRequires: libelf-devel
|
|
BuildRequires: pkgconfig >= 0.21
|
|
BuildRequires: xz
|
|
BuildRequires: pkgconfig(libmnl)
|
|
BuildRequires: pkgconfig(libselinux)
|
|
BuildRequires: pkgconfig(xtables) >= 1.4.11
|
|
Provides: %name-doc = %version
|
|
Provides: iproute = %version-%release
|
|
Provides: %name(xfrm6_raw) = %version-%release
|
|
Obsoletes: %name-doc < 4.15.0
|
|
|
|
%description
|
|
iproute2 is a collection of user-space utilities to set up networking
|
|
under Linux from the command-line. It can inspect and configure,
|
|
among other things: interface paramters, IP addresses, routing,
|
|
tunnels, bridges, packet transformations (IPsec, etc.), and Quality
|
|
of Service.
|
|
|
|
%package -n libnetlink-devel
|
|
Summary: A Higher Level Interface to the Netlink Service
|
|
License: GPL-2.0-or-later
|
|
Group: Development/Libraries/C and C++
|
|
Provides: libnetlink = %version-%release
|
|
|
|
%description -n libnetlink-devel
|
|
libnetlink provides a higher-level interface to rtnetlink(7).
|
|
New programs should use libmnl-devel instead.
|
|
|
|
%package bash-completion
|
|
Summary: Bash completion for iproute
|
|
License: GPL-2.0-or-later
|
|
Group: System/Shells
|
|
Requires: bash-completion
|
|
|
|
%description bash-completion
|
|
bash command line completion support for iproute.
|
|
|
|
%package arpd
|
|
Summary: Userspace ARP daemon
|
|
License: GPL-2.0-only
|
|
Group: Productivity/Networking/Routing
|
|
Provides: iproute2:/usr/sbin/arpd
|
|
|
|
%description arpd
|
|
The arpd daemon collects gratuitous ARP information, saving it on
|
|
local disk and feeding it to the kernel on demand to avoid redundant
|
|
broadcasting due to limited standard size (512..1024 entries,
|
|
depending on type) of the kernel ARP cache.
|
|
|
|
%prep
|
|
%setup -qn %name-%version.0 -a 3
|
|
chmod a+rx %{SOURCE5} %{SOURCE6}
|
|
%{SOURCE5} <%{SOURCE4} | %{SOURCE6} && rm -rf patches
|
|
|
|
%build
|
|
%global _lto_cflags %_lto_cflags -ffat-lto-objects
|
|
# build with -fPIC. For details see
|
|
# https://bugzilla.novell.com/show_bug.cgi?id=388021
|
|
xt_libdir="$(pkg-config xtables --variable=xtlibdir)"
|
|
xt_cflags="$(pkg-config xtables --cflags)"
|
|
%make_build CCOPTS="-D_GNU_SOURCE %optflags -Wstrict-prototypes -Wno-error -fPIC -DXT_LIB_DIR=\\\"$xt_libdir\\\" $xt_cflags"
|
|
|
|
%install
|
|
b="%buildroot"
|
|
mkdir -p "$b/usr/bin" "$b/usr/sbin" "$b/sbin"
|
|
%make_install MODDESTDIR="$b/%_libdir/tc"
|
|
|
|
# We have m_xt instead
|
|
rm -f "$b/%_libdir/tc/m_ipt.so"
|
|
|
|
install -pm0644 "lib/libnetlink.a" "$b/%_libdir/"
|
|
chmod -x "$b/%_libdir/libnetlink.a"
|
|
install -pm0644 "include/libnetlink.h" "$b/%_includedir/"
|
|
chmod -x "$b/%_includedir/libnetlink.h"
|
|
%if 0%{?usrmerged}
|
|
ln -sf "%_sbindir/ip" "$b/%_bindir/ip"
|
|
%else
|
|
ln -s "%_sbindir/ip" "$b/sbin/"
|
|
mkdir -p "$b/bin"
|
|
ln -sf "%_sbindir/ip" "$b/bin/ip"
|
|
%endif
|
|
for BIN in lnstat nstat routef routel ss; do
|
|
ln -sf "%_sbindir/$BIN" "$b/%_bindir/$BIN"
|
|
done
|
|
rm "$b/%_sbindir/ifcfg"
|
|
mkdir -p "$b/%_docdir/%name"
|
|
cp -an README* examples/bpf "$b/%_docdir/%name/"
|
|
%fdupes %buildroot/%_prefix
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%_bindir/lnstat
|
|
%_bindir/nstat
|
|
%_bindir/routef
|
|
%_bindir/routel
|
|
%_bindir/ss
|
|
%_sbindir/*
|
|
%exclude %_sbindir/arpd
|
|
%if 0%{?usrmerged}
|
|
%_bindir/ip
|
|
%else
|
|
/sbin/*
|
|
/bin/ip
|
|
%endif
|
|
%_mandir/man7/*
|
|
%_mandir/man8/*
|
|
%exclude %_mandir/man8/arpd.8*
|
|
%dir %_sysconfdir/iproute2
|
|
%config(noreplace) %_sysconfdir/iproute2/*
|
|
%_libdir/tc/
|
|
%_datadir/tc/
|
|
%_docdir/%name/
|
|
%license COPYING
|
|
|
|
%files -n libnetlink-devel
|
|
%defattr(-,root,root)
|
|
%_includedir/*
|
|
%_mandir/man3/libnetlink*
|
|
%_libdir/lib*
|
|
|
|
%files bash-completion
|
|
%defattr(-,root,root)
|
|
%_datadir/bash-completion/
|
|
|
|
%files arpd
|
|
%_sbindir/arpd
|
|
%_mandir/man8/arpd.8*
|
|
|
|
%changelog
|