lz4/lz4.spec
2024-02-28 21:07:31 +08:00

89 lines
2.4 KiB
RPMSpec
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

#
# spec file for package lz4
#
# Copyright (c) 2022-2023 ZhuningOS
#
%define lname liblz4-1
Name: lz4
Version: 1.9.3
Release: 150400.1.7
Summary: Hash-based Predictive LempelZiv compressor
License: BSD-2-Clause AND GPL-2.0-or-later
Group: Productivity/Archiving/Compression
URL: https://lz4.github.io/lz4/
#Git-Clone: https://github.com/lz4/lz4
Source: https://github.com/lz4/lz4/archive/v%version.tar.gz
Source99: baselibs.conf
Patch2: lz-export.diff
BuildRequires: pkgconfig
%description
LZ4 is a lossless data compression algorithm that is focused on
compression and decompression speed. It belongs to the LZ77
(LempelZiv) family of byte-oriented compression schemes. It is a
LZP2 fork and provides better compression ratio for text files.
This subpackage provides a GPL command-line utility to make use of
the LZ4 algorithm.
%package -n %lname
Summary: Hash-based predictive Lempel-Ziv compressor
License: BSD-2-Clause
Group: System/Libraries
%description -n %lname
LZ4 is a lossless data compression algorithm that is focused on
compression and decompression speed. It belongs to the LZ77
(LempelZiv) family of byte-oriented compression schemes. It is a
This subpackage contains the (de)compressor code as a shared library.
%package -n liblz4-devel
Summary: Development files for the LZ4 compressor
License: BSD-2-Clause
Group: Development/Libraries/C and C++
Requires: %lname = %version
%description -n liblz4-devel
LZ4 is a lossless data compression algorithm that is focused on
compression and decompression speed. It belongs to the LZ77
(LempelZiv) family of byte-oriented compression schemes. It is a
This subpackage contains libraries and header files for developing
applications that want to make use of liblz4.
%prep
%autosetup -p1
%build
V=1 %make_build CFLAGS="%optflags"
%install
%make_install PREFIX="%_prefix" LIBDIR="%_libdir"
rm -f "%buildroot/%_libdir"/*.a
%check
LD_LIBRARY_PATH="%buildroot/%_libdir" ldd -r "%buildroot/%_bindir/lz4"
# TS fails on its own help output
make %{?_smp_mflags} check -k || :
%post -n %lname -p /sbin/ldconfig
%postun -n %lname -p /sbin/ldconfig
%files
%_bindir/lz4*
%_bindir/unlz4
%_mandir/man1/*.1*
%files -n %lname
%_libdir/liblz4.so.1*
%files -n liblz4-devel
%_includedir/lz4*.h
%_libdir/liblz4.so
%_libdir/pkgconfig/*.pc
%changelog