138 lines
3.7 KiB
RPMSpec
138 lines
3.7 KiB
RPMSpec
#
|
|
# spec file for package nftables
|
|
#
|
|
# Copyright (c) 2022-2023 ZhuningOS
|
|
#
|
|
|
|
# configure subpackage rewriter for the python3XX-nftables bindings
|
|
%define python_subpackage_only 1
|
|
# check py/src/nftable.py:NFTABLES_VERSION
|
|
%define pyversion 0.1
|
|
|
|
%define skip_python2 1
|
|
%{?sle15allpythons}
|
|
|
|
Name: nftables
|
|
Version: 0.9.8
|
|
Release: 150400.6.3.1
|
|
Summary: Userspace utility to access the nf_tables packet filter
|
|
License: GPL-2.0-only
|
|
Group: Productivity/Networking/Security
|
|
URL: https://netfilter.org/projects/nftables/
|
|
|
|
#Git-Clone: git://git.netfilter.org/nftables
|
|
Source: http://ftp.netfilter.org/pub/nftables/nftables-%version.tar.bz2
|
|
Source2: http://ftp.netfilter.org/pub/nftables/nftables-%version.tar.bz2.sig
|
|
Source3: %name.keyring
|
|
Patch1: 0001-cache-check-for-NULL-chain-in-cache_init.patch
|
|
Patch2: 0001-evaluate-reject-support-ethernet-as-L2-protocol-for-.patch
|
|
BuildRequires: asciidoc
|
|
BuildRequires: bison
|
|
BuildRequires: fdupes
|
|
BuildRequires: flex
|
|
BuildRequires: gmp-devel
|
|
BuildRequires: %{python_module pip}
|
|
BuildRequires: %{python_module setuptools}
|
|
BuildRequires: %{python_module wheel}
|
|
BuildRequires: python-rpm-macros
|
|
BuildRequires: pkg-config >= 0.21
|
|
BuildRequires: readline-devel
|
|
BuildRequires: pkgconfig(jansson)
|
|
BuildRequires: pkgconfig(libmnl) >= 1.0.4
|
|
BuildRequires: pkgconfig(libnftnl) >= 1.1.9
|
|
BuildRequires: pkgconfig(xtables) >= 1.6.1
|
|
%python_subpackages
|
|
|
|
%description
|
|
nf_tables is a firewalling mechanism in the Linux kernel, running
|
|
independently of and parallel to ip_tables, ip6_tables,
|
|
arp_tables and ebtables. nftables is the corresponsing userspace
|
|
frontend.
|
|
|
|
The nftables frontend features support for sets and dictionaries of arbitrary
|
|
types, meta data types, atomic incremental and full ruleset updates, and,
|
|
similar to iptables, support for different protocols, access to connection
|
|
tracking and NAT and logging.
|
|
|
|
%package -n libnftables1
|
|
Summary: nftables firewalling command interface
|
|
Group: System/Libraries
|
|
|
|
%description -n libnftables1
|
|
libnftables is the nftables command line interface placed into a
|
|
library.
|
|
|
|
%package devel
|
|
Summary: Development files for the nftables command line interface
|
|
Group: Development/Libraries/C and C++
|
|
Requires: libnftables1 = %version
|
|
|
|
%description devel
|
|
libnftables is the nftables command line interface placed into a
|
|
library.
|
|
|
|
This package contains the header files for the library.
|
|
|
|
%package -n python-nftables
|
|
Summary: Python interface for nftables
|
|
Group: Development/Languages/Python
|
|
BuildArch: noarch
|
|
|
|
%description -n python-nftables
|
|
A Python module for nftables.
|
|
|
|
%prep
|
|
%autosetup -p1
|
|
# remove unused shebang
|
|
sed -i '1{/bin/d}' py/nftables.py
|
|
|
|
%build
|
|
mkdir bin
|
|
ln -s "%_bindir/docbook-to-man" bin/docbook2x-man
|
|
export PATH="$PATH:$PWD/bin"
|
|
mkdir obj
|
|
pushd obj/
|
|
%define _configure ../configure
|
|
%configure --disable-silent-rules --disable-static --docdir="%_docdir/%name" \
|
|
--includedir="%_includedir/%name" --with-json \
|
|
--enable-python --with-python-bin="$(which python3)"
|
|
%make_build
|
|
popd
|
|
pushd py
|
|
%pyproject_wheel
|
|
popd
|
|
|
|
%install
|
|
b="%buildroot"
|
|
%make_install -C obj
|
|
pushd py
|
|
%pyproject_install
|
|
%python_expand %fdupes %buildroot/%{$python_sitelib}
|
|
popd
|
|
rm -f "%buildroot/%_libdir"/*.la
|
|
mkdir -p "$b/%_docdir/%name/examples"
|
|
mv "$b/%_sysconfdir/nftables"/* "$b/%_docdir/%name/examples/"
|
|
|
|
%post -n libnftables1 -p /sbin/ldconfig
|
|
%postun -n libnftables1 -p /sbin/ldconfig
|
|
|
|
%files
|
|
%license COPYING
|
|
%_sbindir/nft
|
|
%_mandir/man5/*.5*
|
|
%_mandir/man8/nft*
|
|
%_docdir/%name/
|
|
|
|
%files -n libnftables1
|
|
%_libdir/libnftables.so.1*
|
|
|
|
%files devel
|
|
%_includedir/%name/
|
|
%_libdir/libnftables.so
|
|
%_libdir/pkgconfig/*.pc
|
|
%_mandir/man3/*.3*
|
|
|
|
%files %{python_files nftables}
|
|
%{python_sitelib}/nftables*
|
|
|
|
%changelog
|