Update to sagemath 8.7.

- Drop upstreamed -giac patch.
- Add -sagetex patch to fix a python indentation error.
- Add -rubiks patch to fix compilation of the rubiks library.
- Add -random patch to fix a non-random random bit generator.
- Drop pip3 workaround; the binary is now named just pip again.
This commit is contained in:
Jerry James 2019-04-28 15:12:00 -06:00
parent b6408b9313
commit 05337076b6
21 changed files with 898 additions and 442 deletions

View file

@ -1,7 +1,7 @@
diff -up src/setup.py.orig src/setup.py
--- src/setup.py.orig 2019-01-04 11:05:11.337077724 -0700
+++ src/setup.py 2019-01-16 09:45:32.570933224 -0700
@@ -387,6 +387,9 @@ class sage_build_cython(Command):
@@ -334,6 +334,9 @@ class sage_build_cython(Command):
with open(self._version_file, 'w') as f:
f.write(self._version_stamp)