Update to sagemath 8.5.

Also:
- Bundle ipython again; Fedora version is too far ahead.  Also have to bundle
  prompt_toolkit since Fedora version is too far ahead of bundled ipython.
- Drop LANGUAGES variable setting, now ignored by the sagemath build system.
- Drop unused SAGE_CBLAS variable from /usr/bin/sage.
- Do not force the C locale when launching sagemath.
- Allow the user to override SAGE_DEBUG in /usr/bin/sage.
- Add -ecm, -giac, and -latte patches to fix interactions with external tools.
- Add -sigfpe patch from upstream.
This commit is contained in:
Jerry James 2019-01-17 19:27:08 -07:00
parent eaa777c690
commit 55beead27c
31 changed files with 674 additions and 684 deletions

View file

@ -1,5 +1,6 @@
--- src/setup.py.orig 2018-10-16 09:07:30.086993782 -0600
+++ src/setup.py 2018-10-16 09:10:20.586710425 -0600
diff -up src/setup.py.orig src/setup.py
--- src/setup.py.orig 2019-01-04 11:05:11.337077724 -0700
+++ src/setup.py 2019-01-16 09:45:32.570933224 -0700
@@ -387,6 +387,9 @@ class sage_build_cython(Command):
with open(self._version_file, 'w') as f:
f.write(self._version_stamp)