sagemath/sagemath-buildroot.patch
2019-11-08 08:46:01 -03:00

13 lines
687 B
Diff

diff -up src/setup.py.orig src/setup.py
--- src/setup.py.orig 2019-10-03 16:02:47.728642827 -0300
+++ src/setup.py 2019-10-03 16:03:22.041859763 -0300
@@ -335,6 +335,9 @@ class sage_build_cython(Command):
with open(self._version_file, 'w') as f:
f.write(self._version_stamp)
+ # Remove buildroot paths from the generated files
+ subprocess.run(["find", "build/cythonized/sage", "-type", "f", "-exec", "sed", "-i", "s|@@BUILDROOT@@||g", "{}", "+"], check=True)
+
# Finally, copy relevant cythonized files from build/cythonized
# tree into the build-lib tree
for (dst_dir, src_files) in self.get_cythonized_package_files():