mirror of
https://src.fedoraproject.org/rpms/sagemath.git
synced 2025-04-22 03:39:03 -04:00
Also: - Bundle ipython again; Fedora version is too far ahead. Also have to bundle prompt_toolkit since Fedora version is too far ahead of bundled ipython. - Drop LANGUAGES variable setting, now ignored by the sagemath build system. - Drop unused SAGE_CBLAS variable from /usr/bin/sage. - Do not force the C locale when launching sagemath. - Allow the user to override SAGE_DEBUG in /usr/bin/sage. - Add -ecm, -giac, and -latte patches to fix interactions with external tools. - Add -sigfpe patch from upstream.
13 lines
687 B
Diff
13 lines
687 B
Diff
diff -up src/setup.py.orig src/setup.py
|
|
--- src/setup.py.orig 2019-01-04 11:05:11.337077724 -0700
|
|
+++ src/setup.py 2019-01-16 09:45:32.570933224 -0700
|
|
@@ -387,6 +387,9 @@ class sage_build_cython(Command):
|
|
with open(self._version_file, 'w') as f:
|
|
f.write(self._version_stamp)
|
|
|
|
+ # Remove buildroot paths from the generated files
|
|
+ subprocess.run(["find", "build/cythonized/sage", "-type", "f", "-exec", "sed", "-i", "s|@@BUILDROOT@@||g", "{}", "+"], check=True)
|
|
+
|
|
# Finally, copy relevant cythonized files from build/cythonized
|
|
# tree into the build-lib tree
|
|
for (dst_dir, src_files) in self.get_cythonized_package_files():
|