sagemath/sagemath-buildroot.patch
Jerry James 87098dcde0 Add -buildroot patch and only build cython interfaces once.
Also:
- Drop LANGUAGES variable setting, now ignored by the sagemath build system.
- Drop unused SAGE_CBLAS variable from /usr/bin/sage.
- Do not force the C locale when launching sagemath.
- Allow the user to override SAGE_DEBUG in /usr/bin/sage.
- Add -ecm, -giac, and -latte patches to fix interactions with external tools.
- Add -sigfpe patch from upstream.
- Fix flask_autoindex and flask_openid imports in sagenb.
- Add Education category to the desktop file (bz 1624545).
- Fix SINGULAR_SO variable in /usr/bin/sage (bz 1636759 and 1655248).
- Invoke twistd-2 instead of twistd (bz 1640890).
- Improve jupyter integration (bz 1663165).
- Move existing jupyter integration into the notebook subpackage.
- Require python-jupyter-filesystem instead of owning its directories.
- Drop one more remnant of the F24 to F25 upgrade fixup.
2019-01-19 09:07:04 -07:00

13 lines
682 B
Diff

diff -up src/setup.py.orig src/setup.py
--- src/setup.py.orig 2018-08-29 08:35:19.955079610 -0600
+++ src/setup.py 2019-01-18 11:28:06.915666783 -0700
@@ -386,6 +386,9 @@ class sage_build_cython(Command):
with open(self._version_file, 'w') as f:
f.write(self._version_stamp)
+ # Remove buildroot paths from the generated files
+ subprocess.check_call(["find", "build/cythonized/sage", "-type", "f", "-exec", "sed", "-i", "s|@@BUILDROOT@@||g", "{}", "+"])
+
# Finally, copy relevant cythonized files from build/cythonized
# tree into the build-lib tree
for (dst_dir, src_files) in self.get_cythonized_package_files():