mirror of
https://src.fedoraproject.org/rpms/sagemath.git
synced 2025-04-18 10:19:03 -04:00
Also: - Build for python 3 instead of python 2 due to upcoming python 2 removal. - Add -python3 and -escape patches to fix problems with python 3. - Drop -nofstring patch, only needed for python 2. - Drop upstreamed -eclib patch. - Switch from atlas to openblas and rename -atlas patch to -openblas. - Add -buildroot patch and only build cython interfaces once.
12 lines
647 B
Diff
12 lines
647 B
Diff
--- src/setup.py.orig 2018-10-16 09:07:30.086993782 -0600
|
|
+++ src/setup.py 2018-10-16 09:10:20.586710425 -0600
|
|
@@ -387,6 +387,9 @@ class sage_build_cython(Command):
|
|
with open(self._version_file, 'w') as f:
|
|
f.write(self._version_stamp)
|
|
|
|
+ # Remove buildroot paths from the generated files
|
|
+ subprocess.run(["find", "build/cythonized/sage", "-type", "f", "-exec", "sed", "-i", "s|@@BUILDROOT@@||g", "{}", "+"], check=True)
|
|
+
|
|
# Finally, copy relevant cythonized files from build/cythonized
|
|
# tree into the build-lib tree
|
|
for (dst_dir, src_files) in self.get_cythonized_package_files():
|