mirror of
https://src.fedoraproject.org/rpms/sagemath.git
synced 2025-04-22 19:55:54 -04:00
Update to sagemath 8.4.
Also: - Build for python 3 instead of python 2 due to upcoming python 2 removal. - Add -python3 and -escape patches to fix problems with python 3. - Drop -nofstring patch, only needed for python 2. - Drop upstreamed -eclib patch. - Switch from atlas to openblas and rename -atlas patch to -openblas. - Add -buildroot patch and only build cython interfaces once.
This commit is contained in:
parent
1a0bd1afc6
commit
eaa777c690
19 changed files with 1557 additions and 473 deletions
12
sagemath-buildroot.patch
Normal file
12
sagemath-buildroot.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/setup.py.orig 2018-10-16 09:07:30.086993782 -0600
|
||||
+++ src/setup.py 2018-10-16 09:10:20.586710425 -0600
|
||||
@@ -387,6 +387,9 @@ class sage_build_cython(Command):
|
||||
with open(self._version_file, 'w') as f:
|
||||
f.write(self._version_stamp)
|
||||
|
||||
+ # Remove buildroot paths from the generated files
|
||||
+ subprocess.run(["find", "build/cythonized/sage", "-type", "f", "-exec", "sed", "-i", "s|@@BUILDROOT@@||g", "{}", "+"], check=True)
|
||||
+
|
||||
# Finally, copy relevant cythonized files from build/cythonized
|
||||
# tree into the build-lib tree
|
||||
for (dst_dir, src_files) in self.get_cythonized_package_files():
|
Loading…
Add table
Add a link
Reference in a new issue